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What is a Windows Help File?
To provide an efficient and consistent method of providing help to users of    Windows-based 
applications, Microsoft has devised a system that centers around WinHelp.

The WinHelp application is referred to as the "engine" of the help system because it starts up 
whenever the user requests help. Every time a user opens a help file, Windows executes the file 
"winhelp.exe" and WinHelp is loaded.

The WinHelp engine opens the Windows help files you will create with Visual Help. 



What is Visual Help?
Visual Help is a powerful, easy-to-use development environment for creating Windows help files.

Compared to conventional methods of creating Windows help files, Visual Help's intuitive drag-and-
drop interface makes the assembly of help systems fast and easy. 

Visual Help not only streamlines the process of creating Windows help files, but other on-line 
documents as well, including:

· Procedures Manuals
· Company Databases
· Multimedia Presentations
· Information Guides
· Readme Files
· Shared Network Information
· Electronic Books
· On-line Tests

Thanks to
· Center for computer assistance (714) 753-8050 for producing Visual Help's documentation.
· PEAKDESIGN (510) 531-5331 for producing the VH.WAV file.



How Visual Help Works
A Windows help file is created from a Visual Help project. Visual Help projects are divided into topics.
A topic is defined as the help information displayed in one window by WinHelp during runtime.

Each topic has its own window in the Visual Help development environment. A topic's help 
information is originally placed there when the author drags objects off Visual Help's Objects Toolbox 
onto that particular topic window.

These objects include titles, headings, subheadings, paragraph text, footnotes, and graphics. The 
author enters text into these objects. This design later becomes what the end user sees in the 
WinHelp window upon opening a help file.

In addition to text and graphic objects, the toolbox contains jump objects that you can drag onto your 
topic windows. Jumps provide pathways between topics and create the structure through which the 
user will "navigate."

At any time during assembly of the Visual Help project, the author can test the jumps in the file by 
pressing the play button on the main window toolbar. A simulation of the compiled version of the help 
project appears on the screen, opening to the contents topic. This feature saves a great deal of time 
by eliminating the need to compile the project every time testing is performed.

After assembling and testing the project, it is compiled into a form which WinHelp can open. This is 
an automated process which executes the Windows help compiler, hc31.exe. Upon successful 
completion of the compilation process, the help file is now ready for use. The final product has an 
".hlp" extension, and can be used as a stand-alone document or referenced in the source code of the
parent application.



WinWare
P.O. Box 2923
Mission Viejo, CA 92690 

In addition to Visual Help, WinWare brings you these other fine software products:

Objective Desktop
Windows Program Manager and File Manger replacement that simulates the NeXT desktop.

Brain Games
A collect of seven exciting and challenging Windows games:

Tic-Tac-Toe
The all-time classic

Achi
A Tic-Tac-Toe variant that goes way beyond the traditional game.

Bastille
A peg game.

Battle Sat
"Battleship" style game played in space.

DoubleBlock:
A baffling Windows memory game

Jumper
Try to slide colored tiles into the correct pattern in this brain-baffler.

Knight
move like a chess knight to solve this one.
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Planning the Help Project
Planning your help project is the first and most important step in creating an effective help system.

An important part of this step is to determine who will be using it. Find out the knowledge and 
experience level of your audience. A help system for an 
application used by programmers may need to be quite different from one used by data entry staff.

Now break up the help information into discrete, topic-sized chunks. Make each main idea a 
separate topic, but remember that a topic should only contain enough information to fill one WinHelp 
window. If a topic is lengthy, break it down into smaller units and create a number of smaller topics.

Remember that you will be able to jump from any topic to another, so break the information down into
smaller units when necessary. A user will be able to find information faster by jumping through 
several small topics then by reading the same information by scrolling through a long passage. 
Create a visual representation of the structure of your help project by using a diagram, outline, or 
flow chart.

Guidelines for Contents Topics:

Main Contents Topic
The purpose of the main contents topic is to provide an overview of the contents of the Help system 
and to give clear, logical paths to information. It should work like the table of contents in a book.

Sub-contents Topics
Sub-contents topics open paths from the main contents to individual topics. Jump labels on the main 
contents topic take the user to these topics. They can contain individual topics or more sub-contents 
topics.

Entries can be listed under several different category headings. For example, reference topics and 
procedural topic can be separated.

Entries can be presented by category, as either text jumps or graphic images. List entries in logical 
order (for example, by learning path, frequency of use, or alphabetically).

Try not to include more than 10 entries in topic. Avoid having more than 15 entries, if possible. If your
list is longer than 15 entries, try to break it up into more than one screen.

Try to avoid deeply nested sub-levels so the user doesn't have to jump more than two or three times 
to reach a help topic.

Optimally, a Help topic is one, and at most two screens long. A Help screen is defined as 
approximately one half the width of a maximized window and 1520 lines long. 

Avoid using too many pop-up hot spots on a single screen because they can make the screen hard 
to read.



Creating a New Project
Create a new project by choosing New from the File menu.

It's a good idea to save your project now by choosing Save from the File menu. Name your project 
and save it into the desired directory.

Visual Help project file names have a .vh extension.

Add topics to your new project by clicking on the "T" on the Main Window Toolbar.



Assembling the help project
Using Visual Help's Project Wizard
Working with topics
Working with objects
Defining jumps



Project Wizard
Visual Help's Project Wizard feature allows the user to quickly and easily create the basic structure of
a help project automatically by guiding the user through a series of dialog boxes where the user 
chooses options and edits text boxes.

After the user inputs the desired options and text, the Project Wizard constructs the topics and links 
needed to make up the project. The user simply edits the generic text labels in the assembled help 
project and compiles the project to complete the process.

To create a project skeleton using Project Wizard:
1 Open the Project Wizard by choosing Project Wizard... from the File menu.
2 Enter project option in the first dialog box. Click Next to continue.
3 Select the project style in the second dialog. Click Next to continue.
4 Decide if you want to include an Index. Click Next to continue.
5 Decidfe if you want to include an index. You can define index terms by clicking on the Add/Edit 

Glossary Terms button. Click Finish.
The Project Wizard now creates the foundation for the help project you've specified by creating the 
necessary topics and tying them together with jumps. Go ahead an edit the topics created by Visual 
Help to customize the project to your particular needs.



Working with Topics
Creating a new Topic
Saving a Topic
Printing Topics



Creating a New Topic
Visual Help projects are divided into topics. A topic is defined as the help information displayed in 
one window by WinHelp during runtime. Each topic has its own window in the Visual Help 
development environment.

To create a new topic:
· From the File Menu, select New Topic.

or
· From topic toolbar, click on the first button "T".
· Enter a Topic name in the text box at the upper left corner of the topic window then hit "TAB" Key.
Note: When a new topic is created a title object is automatically inserted at the top of the topic. When
you edit the topic name and press <Tab>, the name will automatically be placed in the title object. 
Delete the title if you do not wish it to be there.



Saving a Topic

Automatic saving
Topics are loaded into memory when they are created and are saved automatically in certain 
situations, such as when the user hits the runtime button to simulate the help file or the file is 
compiled and run.

Manual saving
· Close the topic window from the topic window control box.

or
· Click the disk icon button in the Topic Window Toolbar.



Printing Topics

To print a single topic:
· Open the topic you want to print and make it the current topic. The current topic name will appear

in the drop down list of Visual Help main window.
· Select Print from the File menu. The Print dialog opens.
· Select the "Current Topic" option
· Click OK or press <Enter> to print.

To print multiple topics:
· Open all the topics you want to print by selecting the topics from the main window drop down list 

or from a view window.
· Select Print from the File menu. The Print dialog opens.
· Select the "All Loaded Topics" option.
· Click OK or press <Enter> to print.



Working with Objects
Adding Objects
Editing Objects
Editing Text Objects
Object Popup Menu
Deleting Objects



Adding Objects
You can drag and drop objects from the Object Toolbox onto your topics.
Available objects include titles, headings, subheadings, paragraphs, bullets, jump labels, images, 
glossaries, and indices.

To add an object to the end of a topic:
· Make sure the topic you want to add an object to is visible, then drag the desired object from the 

Object ToolBox and drop onto the topic when the pointer changes into a hand dropping a piece 
of paper.

To insert an object into the middle of a topic:
· Make sure the topic you want to add an object to is visible, then drag the desired object from the 

Object ToolBox over the top of an existing object. Point to the object you want to insert the new 
object above. The pointer will change to a up arrow. Release the mouse to drop the new object.



Editing Text Objects
Edit the text contained in text objects by dragging through the text you want to replace and typing in 
the new words.

Multiline Text Objects
Paragraph and Bullet objects are multiline text objects. If text extends past the end of the line, it will 
wrap to the next line. Press <Enter> to expand the object line by line.

Single Line Text Objects
Title, Heading, SubHeading, and Jump Label Objects are single line text objects. All text entered into 
these objects should be entered on one line. All text will appear after compilation, but you won't be 
able to edit it easily during development.

Tabs
Enter tabs into text objects by pressing the <Ctrl>+<Tab> keys. If you press <Tab> by itself, the 
insertion point moves to the next object in the topic.



Object Popup Menu
Visual Help provides a shortcut to many commonly used object commands through the Object Popup
Menu. You have immediate access to edit and attribute functions by simply pointing to the desired 
object and pressing down on the right mouse button.

The Object Popup Menu is shown at left.



Deleting Objects

To delete an object:
· Click on the object you wish to delete. The insertion point should blink in the topic you want to 

delete.

· Click on the trash button in the Topic Window Toolbar.



Defining Jumps
When a user clicks on a jump label, WinHelp displays another topic. Jump labels are objects that 
provide pathways leading the user quickly to desired information.

Defining jumps:
· Drag a new jump object onto a topic or click on an existing jump object.

· Click on the Action Button on the Topic Window Toolbar (the movie clacker). This opens the 
Action Window.

· Select "Jump to Topic" from the combo box.
· Select the topic you want to jump to from the list.
· Check the "Popup Box" if you want the jump topic to open to a popup window.
· If you want the jump topic to open to a window other than the default "Main" window, choose the 

window type from the Window Name box.
· Click on the OK button or hit <Enter>.



Enhancing the project
Adding Buttons
Adding a Glossary Object
Adding an Index Object
Attaching a Note
Defining Context ID's
Defining a Glossary term
Defining Keywords
Defining a Non-scroll Area
Defining Window Attributes
Defining Winhelp Macros
Designing Images
Playing Sound Files
Using Multimedia Files



Adding Buttons
You can add buttons to the default WinHelp buttons on the top of the help window, and assign 
WinHelp macros to these buttons.

To create and edit buttons:
· Select Button Design from the Window menu.

or
· Click on the Button button on the Main Window Toolbar.
· If no buttons yet exist, begin typing your first button's caption, otherwise select Insert.
· Enter the button name. Then choose the WinHelp macro that will be executed when the button is

pressed.
· Repeat for any new buttons.
· Click on OK to save and exit or Cancel to disregard changes.



Adding a Glossary Object
A glossary is a list of definitions, displayed in popup windows, for terms that may be unfamiliar to the 
to the user.

You can drag and drop a Glossary Object from the tool bar into any topic.The glossary object will be 
compiled just like a glossary at the end of a book, listing all terms in alphabetical order.

To add a Glossary Object:

· Select the Glossary Object in the tool box, then drag and drop like any other object into a topic.
· An icon representing the Glossary Object will be displayed in the topic. You will see the actual 

glossary definitions only after you compile the project.

You can add a Letter Scroll Bar Object which help users find glossary items more quickly by clicking 
on a letter in the bar and scrolling directly to the glossary items that begin with the clicked letter.

· Select the Letter Scroll Bar Object in the tool box, then drag and drop like any other object into a 
topic.

· The    Letter Scroll Bar Object will be displayed in the topic. A non-scroll area is established 
beneath the Letter Scroll Bar Object automatically



Adding an Index Object
An index is a alphabetical list of topic titles and/or keywords.

You can drag and drop a Index Object from the tool bar into any topic. The Index Object will be 
compiled just like a index at the end of a book, with the topic titles and keywords acting as jumps to 
the specified topic.
You have the option of including topic names in the keyword list. Click the check box in the Build 
dialog or the Environment Options dialog to disable/enable this feature.

To add an Index Object:
· Select the Index Object in the tool box, then drag and drop like any other object into a topic.
· An icon representing the Index Object will be displayed in the topic. You will see the actual index 

definitions only after you compile the project.

You can add a Letter Scroll Bar Object which help users find index items more quickly by clicking on 
a letter in the bar and scrolling directly to the index items that begin with the clicked letter.

· Select the Letter Scroll Bar Object in the tool box, then drag and drop like any other object into a 
topic.

· The    Letter Scroll Bar Object will be displayed in the topic. A non-scroll area is established 
beneath the Letter Scroll Bar Object automatically



Attaching a Note
Visual Help provides capabilities for attaching notes to individual topics
to:

· Help remind you of changes or updates that need to be done
· To communicate with another person working on the project
· To store any other information related to the topic

This is a development tool available only while working in Visual Help; the end user won't see or 
have access to these notes.

To attach a note to a topic:
· Activate the topic window you want to attach a note for.

· Click on the pin button in the Topic Window Toolbar. The Notes window opens.
· Edit the note. The time and date will be automatically stamped into the text. Click OK to save the 

new note and exit or Cancel to disregard.



Defining Context ID's
Windows supports context-sensitive help. Context-sensitive help provides the ability for the end user 
to press the F1 key and receive help information about the item that currently has focus.

Developing context-sensitive help requires that the help system author and the application 
programmer agree on a list of context ID numbers so that WinHelp and the application pass the 
correct information back and forth. You can assign context ID numbers arbitrarily or Visual Help will 
generate them for you.

To manually assign context ID's:
From Outline or Browse Window
· Click the Context ID button. The Edit Context ID window opens.
· Enter the new Context ID, then click OK.

From Topic Window
· Click on the Context ID button in the Topic Window Toolbar. The Edit Context ID window opens.

· Enter the new Context ID, then click OK.

Note: If you enter a duplicate context id and click OK, a beep warns you that the ID number already 
exists.

To have Visual Help automatically assign context ID's:
· When you "Build" your project, check the box labeled "Regenerate Context ID's."



Defining a Glossary Term
A glossary term is a definition of a word or phrase, displayed in a popup window, for a term that may 
be unfamiliar to the to the user.

After compilation, glossary entries appear alphabetically a Glossary Object that the user adds to a 
topic.

Glossary entries also become popup jumps in your help text. Their location depends on the settings 
in the "Scope" box of the Glossary Window.

To define a Glossary term:
· Select Glossary from the Windows menu.
or

· Highlight a word in a multiline text object and select the action button in the topic window. The 
Glossary Window opens.

· Enter or edit the Glossary Term.
· Define the scope of the definition. "Global" means the first occurrence of the glossary term will 

become a popup jump for every topic which contains the phrase. Click the "Case Sensitive" 
check box if desired.

· Enter the definition of the term.
· Select OK to accept changes or Cancel to disregard changes and exit.



Defining Keywords
Keywords are used by the end user to search for topics in the help file. 

WinHelp's search dialog relies on a "keyword" list to find topics based on words and phases related 
to the topics.

By default, Visual Help assigns all topic names to the keyword list. If you want to disable this feature 
choose Environment... from the Options menu and uncheck the box.

You can also add additional keywords to a topic by opening that topic and clicking on the Key button 
on the Topic Window Toolbar.

To edit keywords:
· Activate the topic window you wish define keywords for.
· Click on the key button in the topic toolbar. The Keywords dialog opens.

· If the keyword list is empty, begin by typing a new keyword, otherwise click Insert and type the 
new keyword.

· Repeat previous process for all keywords.
· Click OK to save all changes and exit, or Cancel to disregard.



Defining a Non-Scroll Area
Often a topic is too long to fit into one regular sized help window.

When the help information extends below the bottom of the window, a scroll bar automatically 
appears that allows the user to view everything contained in the window by scrolling.

It is often helpful in such topics to freeze the title to remind the user which topic is currently being 
viewed.

To set a non-scroll area:
· Click on the lowest object to be included in the non-scroll area.

· Click on the non-scroll button in the topic toolbar.
· Click on the non-scroll button again to toggle the non-scroll area off.



Defining Window Attributes
You may need to vary the size, shape, and color of topic windows depending on the quantity and 
formatting of the help information inside. 

Visual Help provides the capability of creating window "styles" which determine the appearance of a 
topic when it opens.

To define window styles:
· Open the Window Design dialog by choosing Window Design from the Windows menu.

or
· Click on the window button on the Main Window Toolbar.
· Select the name of the window you want to change.
· Enter the desired caption for the selected Window which will appear in the title bar of the window 

after compilation.
· If you want the window to always remain on top, check the box.
· Choose an option for the window size. Designate the "current size" setting by resizing the 

window itself.
· Click on OK to save or Cancel to disregard changes and exit.



Defining WinHelp Macros
The WinHelp application provides macros you can access through Visual Help. These macros 
automatically perform common WinHelp tasks like moving between topics, printing, and displaying 
dialog boxes.

To assign WinHelp macros:
· Select the jump label or image object you want to assign a WinHelp macro to.

· Click the Action button in the Topic Window Toolbar to open the Action dialog.
· Select the "WinHelp Macro" from the combo box.
· Choose the macro you want to assign from the list.
· Click OK or press the <Enter> Key.



Designing Images
The image design features of Visual Help let you to create label and button graphic objects from text.

After you enter and format the desired text, you save it as a graphic file. Then use that file, just like 
any other graphic, as the basis for a jump to another topic or a WinHelp macro.

To create an image:
· Select Image Design from the Window menu.

or
· From the Main Window toolbar click on the camera button.
· Enter a path and filename for an Icon, Bitmap, or Windows meta file in the image text box, or 

leave blank.
· Type in text in the text box, then select the attributes for the text from the window. Visual Help 

previews the image at the bottom of the dialog.
· Click Save to save the image. Name the file and save it to the appropriate directory. The image is

now ready to be used by Visual Help.



Playing Sound Files
Visual Help supports the use of Windows sound files (.wav) in a help project. A sound file can be 
assigned to a jump object just like a topic or WinHelp macro.

 If your system supports sound, click on this Visual Help icon.

Make sure any sound files you want to use are contained in the same directory as the project. Sound files
will only work on systems that support sound and have the proper drivers installed.

To assign a sound file:
· Select the jump label or image object you want to assign a sound to.

· Click on the Action Button on the Topic Window Toolbar (The movie clacker). The Action dialog 
opens.

· Select "Play Media" from the drop down list.
· Select the Sound file you want to play on selection from the list. (Any sound files you want to 

include must be in the same directory as the help file).
· Click OK or press <Enter>.



Using Multimedia Files

Visual Help supports the use of Windows Audio/visual files (.avi), multimedia viewer files (.mmm), 
and MIDI files (.mid).
You must have the proper hardware and software drivers installed to take advantage of multimedia 
capabilities in your help project. Contact Microsoft for more information about Window's multimedia 
capabilities.

To incorporate a multimedia object into your help project, drag a multimedia object onto a topic. 
Double-click on the MCI icon and assign the    desired multimedia file through the Load Image dialog 
box.

Since you cannot test multimedia objects with Visual Help's runtime test feature, you must compile 
the project to enable the multimedia functions. After you compile the project, a Play and Stop button   
will be placed into the topic at the location of the MCI object. Click on the Play button to test the 
multimedia file.



Preparing the project for use
Testing the Help File
Making the Help File



Testing the Help File
Visual Help saves development time with runtime testing of jumps and sound files without compiling 
the help project.

Runtime testing:

· Click the "runtime start" button on the Main Window toolbar to emulate the compiled help project.

· Click the "runtime stop" button when finished.



Making the Help File

Build
· Select Build from the Compile menu. Visual Help will create all files necessary for the help 

compiler to compile the help file.

Compile
· From the Compile Menu, select Compile. The help compiler generates the help file.

Run
· From the Compile Menu, select Run.    Visual Help executes WinHelp and opens the compiled 

help document.

All the above
· From the Compile Menu, select All the Above. Visual Help builds, compiles, and runs the help file

all at once.

Note: If you are using a pif file for the help compiler, make sure that the window closes on exit.



Options
Project Options
Environment Options
Define Styles



Project Options
Project options control how visual help files are created, processed, and optimized.

The only project option you'll probably need to adjust is the "Title" option, which determines the text 
displayed in the title bar of the help file when it opens.

Do not adjust any other project options unless you're familiar with the effects of adjusting these 
options or you are experimenting on a practice file. Except for the title, project options defaults are 
set so that no adjustment is necessary for normal operation of Visual Help.

Editing project options:
· Select Project Options from the Options menu. The project dialog opens.
· From the combo box select the options category to edit. The [Options] category contains the 

options most frequently adjusted.
· From the list select the option to edit. A text box or combo box will appear on top of the list 

indicating current value.
· Edit the selection value.
· Click Ok to save or Cancel to disregard and exit.

Startup Topic "Contents"
The first topic saved becomes the startup topic. You can designate another topic as the startup topic 
by modifying the project option "Contents." Click on the Contents option and choose the desired topic
from the drop down list.



Environment Options
Environment options control various aspects of the Visual Help working environment that effect all 
Visual Help projects.

Help Compiler
The name and path to the help compiler. If the help compiler exists in the DOS path then just enter 
the name. Click "Browse" to locate the help compiler.

Regenerate Context Ids
If checked, Visual Help will regenerate all context ID's in the .hh file. This option resets to false after 
the first build, to ensure that user-defined context ID's are not overwritten the next time the project is 
built.

Add topic name to Keywords list
If Checked, Visual Help will add the Topic name to the keyword list automatically. (Default is true)

To adjust the Environment options:
· Choose Environment from the Options menu to open the Environment Option dialog.
· Adjust options as necessary.
· Click Ok to save and exit or Cancel to disregard.



Defining Styles
A style is the look of a text object such as a title or paragraph in the help document.

Since users of Windows help systems have come to expect a certain look and format, Visual Help 
has default styles for text objects that follow    WinHelp conventions.

Modify an existing style by selecting it from the Styles list, then choosing the desired options from the
accompanying option buttons and boxes. Any existing topics which contain the altered style(s) will be
changed to reflect the new style.

To edit styles:
· Select Styles... from the Options menu. The Define Styles dialog opens.
· Select the style you want to edit from the list.
· Edit the style by selecting attributes. Visual Help previews the style in the Sample box.
· Click OK to save and exit or Cancel to disregard.



Reports
Topics List
Topics Outline
Project Options



Topics List Report
This report generates a list of all topics in the project including context ID's.

To generate a Topics List report:
· Select Topics List from the Reports menu. The Topics List report window opens.
· Click Print to print the report



Topics Outline Report
Generates a report of topics listed in an outline form according to hierarchy of the help file. This 
report includes browse sequence numbers.

To generate a Topics Outline report:
· Select Topics Outline from the Reports menu. The Topics Outline window opens.

or
· Click on the outline button on the Main Window Toolbar.
· Click Print to print the report.



Project Options Report
This report will print all current Project Options in the project file.

To generate a Project Options report:
· Select Project Options from the Report menu. The Project Options window opens.
· Click Print to print the report.



Import and Export
Import
Export



Import
Import VH projects



Importing other Visual Help Projects
Use the Import... command to get topics from other Visual Help projects. This feature allows you to 
merge projects or use an existing project as a template.

To import topics from other projects:
· Select Import... from the File menu.
· Locate the desired Visual Help project file (.vh). Click OK.
· The Import Wizard window opens with all available topics in the list box on the left.
· Select all Topics you want to import into the current project. Use the <Shift> key to select a 

continuous range of topics. Use the <Ctrl> key to select discontinuous ranges of topics.
· Click Import to continue.
· If duplicate topic names are encountered, Visual Help prompts you to rename the topic.

Note: If you wish to import help information from other sources, use Copy and Paste to place the 
information into Visual Help text objects.



Export
Export to manual
Export include files



Export to Manual
A word processing document can be generated from a help project. This document can then be used
to create a printed manual.

The document will be a RTF (Rich Text Format) document, which can be opened by many word 
processing programs including Microsoft Word. During the export process, Visual Help's styles are 
translated as follows:

Title = Heading 1
Heading = Heading 2
Sub-heading = Heading 3
Paragraph = Normal

The outline of the manual will be the same as the outline view hierarchy.

To generate a manual:
· Select Export from the File menu to open the Export Wizard.
· Select Manual option. Click Continue.
· Select Rich Text Format or Text file. Click Continue.
· Enter file name and path to export to. If no path name is entered, the file will be exported to the 

default Visual Help directory.
· Click Continue to generate the manual.



Export Include Files
An include file is a file generated by Visual Help that a programmer can include to reference context 
IDs in the help file. Files for BASIC, Pascal, and C developers can be generated.

By defining constants for the context ID's which use the name of the topic, the programmer can avoid
problems which arise from changing context ID numbers.

Note: Visual Help automatically exports context ID definitions into a file with an .hh extension which 
only includes the ID's for generated topics.
To generate an include file with all topics ids (even the ones not built in the help file), you need to 
export an include file.

To generate an include file:
· Select Export... from the File menu to open the export Wizard.
· Select the "Include file" option. Click Continue.
· Select the desired programming language. Click Continue.
· Enter the file name and path to export to. If no path name is entered, the file will be exported to 

the default Visual Help directory.
· Click Continue to generate the include file.
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Toolbars
Main Window Toolbar
Topic Window Toolbar
Objects Tool Box



Main Window Toolbar
Click on a button for information about its function.



Topic Window Toolbar
Click on a button for information about its function.



Objects Tool Box
Click on a button for information about its function.



Menu Commands
Click on a menu option to get help information:



Tips, Tricks, and Advice
· When you create a new topic, go directly to the topic name box and enter the topic name. Press 

<Tab> to lock in the name and copy it directly to the title object.
· To create a new topic for an existing jump label, press the <Ctrl> key and click on the jump label.
· To go to the topic that is assigned to a jump label, hold down the <Ctrl> key and click on the jump

label.
· Use the runtime testing feature of Visual Help to test jumps and sound files without having to 

compile the project.
· Give your topics logical names that will make good keywords for WinHelp search. Visual Help 

includes topic names in the keyword list by default.
· Use the Find... command under the Edit menu to help you locate topics in projects with a large 

number of topics. You can search by typing in any letter, word, or phrase which is contained in 
the title object of the topic you are seeking.

· Limit the number of open topic windows to conserve system resources.
· Match the text in jump labels to the name of the topic it jumps to.
· Help speed the execution of WinHelp by converting 256 color (or greater) bitmaps to 16 color.
· Wait until the end of the development cycle to link images to your image objects. The help 

compiler executes faster when no images are included, reducing help system development time. 
Compilation speed is also improved by deselecting the Generate Index Objects and Generate 
Glossary Objects check boxes in the build dialog until needed.

· Although the first topic created is assigned by default to be the Contents Topic, you can 
designate any topic as the Contents topic. The topic window that is designated as the Contents 
topic is the first topic displayed by WinHelp upon loading the help file. To designate a topic as the
Contents topic, select Project from the Options menu. Click on Contents in the list of project 
options, then select the topic you want to be designated as the Contents topic.

· You can also give your help project a title by selecting Project from the Options menu. Click on 
Title from the list of project options, then type the title for your help project. This title will appear in
the title bar of each window when the help file is compiled and run.

· You assign a jump, sound, or WinHelp macro to a bitmap by clicking on the action button and 
choosing the desired action. Bitmaps can also be aligned to the left or right by clicking the Align 
buttons.

· You can speed up the compilation process by defining a temp directory on a RAM drive. If you 
have abundant RAM, add the line evice=c:\windows\ramdrive.sys to your config.sys file. This 
creates a fast virtual drive in RAM that the Help Compiler uses when it compiles your project. 
You also need to specify add to your autoexec.bat file the lines md x:\temp (where x is the drive 
designation for the created RAM drive) and temp=x:\temp. Do not assign the root directory of 
your RAM drive to be the emp directory (temp=d:) because your can encounter problems with 
the DOS convention of allowing only 64 files on the root directory of any DOS drive.

· The Help Compiler needs plenty of hard disk and RAM memory to function    properly. Make sure 
you have enough of each.

· If your help project takes a long time to compile, you can assign it to work in the "background" by
creating a Windows .pif file for the Help Compiler which specifies windowing and background 
attributes. Make sure you also select the "Close window on exit" checkbox.
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A
About dialog
About
Add Buttons
Adding buttons
Adding Glossary Object
Adding Index Object
Adding index objects
Adding Objects
Adding other objects
All the above
Altering text
Assembling the help project
Assembling the help project
Attach Note
Attaching notes



Automating tasks

B
BASIC language support
Benefits of registration
Bitmap Design
Browse
Build
Building the help file
Button Design
Buttons

C
C language support
Changing window shape
Character map
Coloring windows
Compile Menu
Compile
Compiling the help file
Compuserve Registration
Contents all
Contents Help
Contents Introduction
Contents Procedures
Contents Reference
Contents Registration
Contents
Contents
Context ID export
Context ID's definition
Copy
Creating a help file
Creating a new Project
Creating a New Topic
Creating custom labels and buttons
Cut

D
Define Context Id
Define Glossary term
Define Jumps
Define Keywords
Define Non Scroll Area
Define Styles



Define Windows attributes
Define WinHelp Macros
Defining context ID's
Defining glossary terms
Defining jumps
Defining keywords
Defining non-scroll area
Defining styles
Defining window attributes
Defining WinHelp macros
Delete
Deleting Objects
Deleting text
Description of Visual Help processes
Design Images
Designing images
Designing windows
Documentation
Drag and drop objects

E
Edit commands
Edit Menu
Editing Objects
Editing text objects
Editing Text Objects
Enhancing the help project
Enhancing the project
Environment Options
Environment
Exit
Export functions
Export include files
Export menu
Export procedures
Export to Manual
Exporting include files

F
File commands
File Menu
Find Next
Find Previous
Find
Freezing titles



G
Generating context ID's
Generating include files
Glossary Menu
Glossary object adding
Glossary terms

H
Hardware requirements
HC31.exe
Help commands
Help Compiler
Help contents
Help file definition
Help Menu
Help project assembly
Help project assembly
Help project compilation
Help project compilation
Help project enhancement
Help project enhancement
Help project planning
Help project testing
How to...
How to...
How vh works
How Visual Help works

I
Image Design
Image Design
Import and Export
Import functions
Import menu
Import procedures
Import Wizard
Import Wizard
Importing topics from other projects
Include files
Index object adding
Index
Index
Introducing VH
Introduction



Introduction

J
Jumps

K
Keywords

M
Macro definition
Mail Registration
Mail-in registration
Main button design
Main help
Main image design
Main new
Main open
Main outline view
Main runtime end
Main runtime start
Main save
Main topic combo
Main window design
Main Window Tool Bar
Main Window Toolbar
Making the help file
Making the Help file
Manual
Menu commands
Menu Commands
Multimedia capabilitites
Multimedia
Multiuser pricing

N
New project creatation
New topic
New Topic
New
Non-scroll area
Notes

O
Object deletion
Object editing
Object Popup Menu
Objects in topics



Objects Tool Box
Objects Toolbox
Open
Option commands
Options Menu
Options
Options
Other Winware products
Outline report
Outline

P
Paint brush
Pascal language support
Paste
Planning the help project
Planning
Playing sound files
Playing Sound Files
Preparing the project for use
Print Registration form
Print
Printing a list of topics
Printing project options
Printing project outline
Printing topics
Printing Topics
Procedures section
Procedures section
Product Support help
Product support
Product Support
Programmer support
Project Options Report
Project options report
Project Options Reports
Project options
Project Options
Project templates
Project Wizard
Project

R
RAM requirement
Reference section



Reference
Registration benefits
Registration by mail
Registration by telephone
Registration fee
Registration overview
Registration through Compuserve
Registration
Remove Topic
Removing objects from topics
Replacing text
Report commands
Reports Menu
Reports overview
Reports
Reusing topics
RTF manual
Run
Running the help file
Runtime testing

S
Save As
Save
Saving a Topic
Saving topics
Search
Secondary Windows
Shed editor
Site license pricing
Software requirements
Sound recorder
Sound
Starting a new project
Styles
Styles
Support
System requirements
System Requirements

T
Technical support
Telephone registration
Telephone Registration
Testing jumps without compiling



Testing the Help file
Testing the help project
Text object editing
Text styles
Tips and tricks
Tips and Tricks
Tool Bars
Tool Box
Toolbar overview
Toolbox bitmap jump
Toolbox bitmap paragraph
Toolbox bullet
Toolbox footnote
Toolbox glossary
Toolbox heading
Toolbox Image
Toolbox index
Toolbox jump
Toolbox letter scroll bar
Toolbox line
Toolbox monospaced
Toolbox numbered
Toolbox paragraph
Toolbox subheading
Toolbox title
Topic action
Topic align left
Topic align right
Topic close
Topic context id icon
Topic context id
Topic down arrow
Topic image
Topic keyword
Topic name
Topic nonscroll
Topic Note icon
Topic note
Topic printing
Topic Properties
Topic save
Topic saving
Topic trash



Topic up arrow
Topic Window Tool Bar
Topic window toolbar
Topics list report
Topics List Report
Topics List
Topics outline report
Topics Outline Report
Topics Outline
Trash

U
Using other Visual Help projects

V
View commands
View Menu
Visual Help explained
Visual Help overview

W
What do you get
What is a Window help file
What is vh definition
What is vh jump
What is Visual Help
What is Windows help file
Why register
Window attributes
Window commands
Window design
Window Design
Window Menu
Windows help engine
Windows
WinHelp macros
WinHelp
WinWare
WinWare
Working with objects
Working with objects
Working with topics
Working with topics
Written documentation
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 Procedures
 Reference
 Registration
 Registration by Mail
 Registration through Compuserve
 Registration by phone "Credit Card Orders"
 What you receive...
 Product support



Registering Visual Help V2.0
(To print the following form, select Print Topic from the File menu.)

Please register my copy of Visual Help. I am sending a check or money order for the amount of 
$49.00.

Name:

Company:

Address1:

Address2:

City: State: Zip:

Country:

Tel: Fax:

Email:

Single-User Registration
Single user .................................................................................$49.00

Multi-User Registration (Site license)
10 to 20 users ...............................................................................$400.00
21 to unlimited ...............................................................................$700.00

Amount enclosed ...........................................................................................



Send completed form with payment to
WinWare
P.O. Box 2923
Mission Viejo CA 92690

Where did you here about Visual Help

Notes



Compuserve Registration
To register through CompuServe, you need to have a CompuServe account.

· Log on to Compuserve
· At any prompt type "GO SWREG"
· Select registration Id# "891".

The registration fee will be billed to your CompuServe account.



Telephone Registration
You can order with MC, Visa, Amex, or Discover from Public Software Library by calling:

· 800-2424-PSL
or

· 713-524-6394
or by FAX at

· 713-524-6398
or by CIS Email to 71355,470. 

You can also mail credit card orders to:

PsL 
P.O.Box 35705 
Houston, TX 77235-5705. 

Make sure to specify "Visual Help"    order #10851, $49.00 will be billed to your credit card. If you 
order by mail or Fax be sure to include the expiration date of your credit card.

THE ABOVE NUMBERS ARE FOR ORDERS ONLY. Any questions about the status of the shipment 
of the order, registration options, product details, technical support, volume discounts, dealer pricing, 
site licenses, etc, must be directed to WinWare at the address bellow or CIS Email 70272,1656.

Questions, Support, and site licenses contact
WinWare
P.O. Box 2923
Mission Viejo CA 92690

or

CompuServe 70272,1656.



Registered Users Receive:

Latest Version of Visual Help
· Sample help projects on disk.
· Extensive printing and reporting capabilities.
· Extensive programmer support.
· Import and Export capabilities.
· Help to Manual features to convert your help files into printed manuals.

Ongoing product support
· Through Compuserve. (CIS ID # 70272,1656)
· Through 24 hour BBS support. The WinSIG BBS number is 714-363-9802 (2400/9600-N-8-1).

New releases
· Notification of new releases.
· Minimal charges for upgrades.



Product Support
Product Support for Visual Help is available through the following channels. Please include the 
version of Visual Help you are using and your system configuration.

Compuserve
Please direct questions to:

Firas Bushnaq (Visual Help Tech Support)
70272,1656

WinSIG BBS
Please direct questions to:

Firas Bushnaq
714-363-9802      2400/9600/14400 -N-8-1



About
Opens the "about Visual Help" dialog box.



All the above
Build, compile, and run the help file.



Image Design
Opens the Image Design window.



Browse
Opens the Browse view window.



Build
Builds the help document .rtf and .hpj files. These are files used by the help compiler to generate the 
Help (.hlp) file.



Button Design
Opens the Button Design window.



Character Map
opens Window's "Character Map" application for inserting special characters into your work.



Compile
Compiles the .hpj and .rtf files using the help compiler to generate the help (.hlp) file.



Compile Menu
Click on a command to get help information:



Contents
Go to the contents of this help file.



Copy
Copy selected text and place on the Windows clipboard.



Cut
Remove seleced text and place on the Windows clipboard.



Delete
Remove selection (do not place on the Windows clipboard).



Edit Menu
Click on a command to get help information:



Editing Objects
Visual Help provides powerful object editing capabilities that speed the development of your help 
project. By taking advantage of the Windows clipboard, cut, copy, and paste techniques, as well as 
Visual Help's powerful object popup menu, you can dramatically reduce development time.

Visual Help takes full advantage of the Windows clipboard by providing Edit functions for both text 
and object transfer.

· Text - to transfer text between two Visual Help text objects, highlight the desired text in the object
that you will be cutting or copying from. Copy the highlighted text to the clipboard by choosing 
Copy from the Edit menu (or Ctrl+C) if you wish to retain the source text.

Choose Cut (or Ctrl+X) from the Edit menu to remove the source text and place it in the 
clipboard. Click on the object you wish to paste to, making sure the insertion point is at the place 
where you wish to paste the text contained in the clipboard. Choose Paste (or Ctrl+V) from the 
Edit menu. 

Only text material can be pasted into a text object. Text from other applications also can be 
transferred to and from Visual Help objects via the clipboard.

· Objects - Entire Visual Help objects can also be cut, copied, pasted, and duplicated. imply click 
on the object you wish to cut or copy to the clipboard to highlight it.

Note: If you wish to cut or copy an entire text object, be sure that the insertion point is blinking in 
the object but no text is highlighted. If any text is highlighted, just the highlighted text will be 
placed on the clipboard. Choose Cut or Copy from the Edit menu. Select the topic you wish to 
paste to by clicking anywhere on the window and choose Paste from the Edit menu.

You can also "clone" any object by selecting the object and choosing duplicate from the Edit 
menu. To remove an object from a topic, highlight the object and choose Delete from the Edit 
menu.



Environment
Opens Environment Options dialog where you adjust the help compilier location, automatic 
regeneration of context ID's, and addition of topic names to the keyword list.



Exit
Quit Visual Help with the option of saving current changes.



Export
Opens the Export Wizard. To create Rich Text Format Manuals and Include files to support C, Pascal
or Basic.



File Menu
Click on a command to get help information:



Find
Opens the Find dialog, used to find a topic by entering a part of the topic name or title text within.



Find Next
Find next occurrence of text specified in the Find dialog.



Find Previous
Find previous occurrence of text specified in the Find dialog.



Glossary
Opens the Glossary dialog.



Help Menu
Click on a command to get help information:



Image Design
Opens the Image Design window



Import
Opens the Import Wizard to import topics from other Visual help projects.



Introducing Visual Help
Opens the Introduction Topic of Visual Help help.



What is Visual Help?
What is Visual Help?
What is a Windows help file?
How Visual Help works



Button Design
Opens the Button design dialog.



Help
Opens Visual Help's help file.



Image Design
Opens the Image design dialog.



New Topic
Creates a new topic.



Open File
Opens an existing Visual Help project.



Outline View
Opens the outline view of your Visual Help project.



Runtime End
Ends the runtime testing of your Visual Help project.



Runtime Start
Starts the runtime testing of your Visual Help project.



Save Project
Saves your Visual Help Project.



Topic
Topic Combo Box, use it to select the topic you want to view or edit.



Window Design
Opens the Window design dialog.



New
Creates a new project file, with options to save the current project.



New Topic
Creates a new topic in the current project.



Open
Opens an existing project file, with options to save the current project.



Options Menu
Click on a command to get help information:



Outline
Opens the Outline window.



Paint Brush
opens Window's Paint Brush application



Paste
Paste selection from the clipboard.



Print
Opens the Print dialog to print individual topics.



Print Registration Form
Prints a form for registering by mail.



Product Support
Displays information on Visual Help product support.



Project
Opens the project dialog for adjusting project options.



Project Options Report
Opens the Project Options window which lists all current project options.



Reference
Menu Commands
Toolbars
Tips, Tricks, and Advice
Index



Registration
There are three easy ways to register Visual Help. The registration fee for individual users is $49.00. 
For site license pricing click on "Registration by Mail."

Registration by Mail
Registration through Compuserve
Registration by phone "Credit Card Orders"
What you receive...
Product support



Remove Topic
Deletes the current topic from the project.



Reports Menu
Click on a command to get help information:



Run
Starts up WinHelp and runs the lastest compiled version of the current project.



Save
Saves the current help project.



Save As
Saves the current help project under a different name.



Search
Opens the Winhelp search dialog for the Visual Help help file.



Shed Editor
starts up the "Hotspot Editor."



Sound Recorder
opens Window's Sound Recorder application.



Styles
Opens the Styles dialog. Used for changing text attributes like font, sizes, colors, etc.



System Requirements

Hardware Requirements
· Personal Computer using an 80286 or higher microprocessor (80386 is recommended)
· 2 MB RAM (4 MB recommended)
· EGA, VGA, super VGA, XGA, 8514/A or compatible video graphics card.
· Hard drive with at least 1 MB free space
· Mouse.

Software Requirements
· MS DOS operating system version 3.1 or later.
· Microsoft Windows version 3.1 or later.
· Microsoft Windows Help Compiler version 3.1 or higher. This file is named hc31.exe or hcp.exe. 

The file is included with Visual Basic Professional, the Microsoft SDK (Software Development 
Kit), and most other Windows development tools. This compiler takes the information from your 
Visual Help project and converts it into a format recognized by the WinHelp engine.



Tool Box
Opens the Objects toolbox.



Bitmap Jump Label
Bitmap and a single line jump text object.



Bitmap Paragraph
Bitmap and multiple line text object.



Bullet
Bulleted multiple line text object.



Footnote
Single line footnote text object.



Glossary
Inserts the project glossary after compilation.



Heading
Single line heading text object.



Image
Image object.



Index
Inserts the project index after compilation.



Jump Label
Single line jump text object.



Letter Scroll Bar
Help users reach help index and glossary information quickly.



Line
Graphic object used to separate other objects.



Mono-spaced Paragraph
Multiple line text object used for tables, code samples, or any other text which requires a mono-
spaced font.



Enumerated Bullet
Enumerated multiple line text object.



Paragraph
Multiple line text object.



Sub-heading
Single line subheading text object.



Title
Single line title text object.



Action Button
Defines a jump, macro, sound, or a glossary defintion action for a jump object.



Align left
Aligns objects to the left side of the topic page.



Align Right
Aligns objects to the right side of the topic page.



Close Topic Button
Closes a topic without saving changes.



Context Id Button
Manualy assigns a context ID to a topic.



Context ID
Shows when a Context ID is assigned to the Topic.



Down Button
Moves an object down one position in a topic.



Image Button
Assigns a bitmap or hypergraphic file to an object.



Keyword Button
Adds, edits, and deletes topic keywords.



Topic Name
Enter a new topic name or edit an existing topic name.



Non-scroll Button
Toggles the non-scroll area on or off below a selected object in the help topic.



Note Button
Assigns a note to the topic.



Note Icon
Shows when a note is attached to this topic. Double Click to view the note.



Topic Properties Button
Opens the topic properties dialog box.



Save Topic
Saves the currently selected topic to disk.



Trash Button
Deletes the selected object from the topic.



Up Button
Moves an object up one position in a topic.



Topics List
Prepares a report of all topics in alphabetical order.



Topics Outline
Generates a report of topics listed in an outline form according to hierarchy of the help file.



View Menu
Click on a command to get help information:



What is Visual Help
What is Visual Help?
What is a Windows help file?
How Visual Help works



Window Design
Opens the Window Design dialog.



Window Menu
Click on a command to get help information:






